Общее описание IPv6 туннеля


Настройка тунеля крайне проста на вашем сервере или wifi роутере крайне проста. Единственным условием является наличие прямого (статического) IP адреса от вашего провайдера. Его всегда можно заказать или попросить у вашего провайдера. Сайт тунельного брокера IPv6 IP4Market автоматически видит Ваш IPv4 адрес и вносит его в базу. Система назначает пользователю сеть IPv4 /48 из своего пула и инкапсулирует весь приходящий на в нее трафик в IPv4 и отправляет на IP адрес пользователя. Роутер или компьютер пользователя извлекает пакеты IPv6 и передает их в сеть пользователя или систему.

При регистрации базово выделяется сеть /48. Из нее выделянется 2 сети /64,
Первая сеть назначается для туннеля 6in4,
адрес ::1 - принадлежит брокеру
адрес ::2 - выделяется для роутера пользователя.

Вторая сеть предназначена для всех устройств пользователя расположенных за роутером. Ее нужно просто вписать в настройки роутера.

Настройка IPv6 туннеля


При регистрации выделяются номера сетей:

Сеть IPv6: 2a03:e2c0:1dc:5555::/64 - это сеть которая будет разадваться клиентам. Нужно указать ее в роутере как полученный префикс IPv6

Обычно это:
network: 2a03:e2c0:1dc:5555::
prefix: 64

IPv6 Клиента: 2a03:e2c0:1dc::2/64
указать его как Tunnel Client IPv6 адрес


IPv6 Шлюз: 2a03:e2c0:1dc::1/64 - обычно параметр опциональный, умный роутер сам разберется с IP адресом сервера.

Сервер для подключения: 193.0.203.203 - адрес на который Ваш роутер или компьютер будет отправлять пакеты с IPv6 трафиком.

Чтобы был резолв доменов необходимо указать также DNS сервера, для примера мы берем сервера публичные сервера Google

IPv6 ДНС:
2001:4860:4860::8888
2001:4860:4860::8844

Также есть DNS v6 адреса от Yandex-а

2a02:6b8::feed:0ff
2a02:6b8:0:1::feed:0ff

Пример для настройки Mikrotik


/interface 6to4 add !keepalive local-address=ХХ.XX.XX.XX mtu=1480 name=6to4-tunnel1 remote-address=193.0.203.203
/ipv6 address add address=2a03:e2c0:XXX::2/64 interface=6to4-tunnel1
/ipv6 route add distance=1 dst-address=2000::/3 gateway=2a03:e2c0:XXX::1
/ipv6 address add address=2a03:e2c0:XXX:5555::/64 interface=bridge advertise=yes


Пример настройки IPv6 туннеля на прошивке TOMATO для wifi роутеров

Пример того как выглядит настройка:



Я не разобрался! Что мне делать?

Первое - не паниковать ) Далее прочитать документацию в панели управления своего роутера по настройке IPv6.
Спросить помощи и совета можно в Телеграм канале @ip4market
Обсудить IPv6 с единомышленниками можно в другом Телеграм канале @ru_ipv6

Если совсем все тяжело или сложный случай - можно посмотреть техническую документацию на сайте другого тунельного брокера https://forums.he.net/.
Там разобраны все самые экзотические случаи по его настройке на любом оборудовании.